PlanetBids - Elevated error rate with Insurance Certificate Management – Incident details

System Status

Elevated error rate with Insurance Certificate Management

Resolved
Partial outage 5 %
Started 11 days agoLasted 39 minutes

Affected

Agency Hub

Partial outage from 3:37 PM to 4:15 PM

Updates
  • Postmortem
    UTC
    Postmortem

    With the release of the new Insurance Certificates UI, a new query was introduced to match new data access patterns. In pre-production, testing did not reveal any performance issues. Upon releasing to production, the data volume of InsCert and InsCov yielded resulted in scans and seeks in the absence of indexes. After adding a covering index to InsCov, we saw database pressure release.

    After further investigation, we were able to identify 4 additional indexes to create to further improve performance of the new Ins Cert search.

  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Investigating
    UTC
    Investigating

    Some agencies are experiencing an elevated error rate for Insurance Certificates. We are currently investigating this incident.